Views: 537
Last Modified: 02.04.2021

Apache used as backend is a standard package, with up-to-date version from EPEL-repository.

PHP – standard packages from REMI-repository. BitrixVM virtual appliance supports option to update from PHP version from 5.6 to 7.2, as well as downgrade back (version 7.3 is pending).

When installing bitrix-env, the following configurations are created for Apache:

  • for site and service with modules, required for site operation.
  • for existing server, depending on the available server memory and virtualisation type – these settings are applied when loading the server and are configured for specific environment.
  • for additional PHP modules.

Option for extra config setup from virtual appliance menu scenarios:

  • enabling and disabling PHP modules, required for operation.
  • enabling NTLM authorisation via the Apache module.
  • updating PHP version from 5.6 to 8 and back.
  • creating several backend servers for paralleling workload.



Courses developed by «Bitrix», Inc.